VitaPad 1.0 — Help Manual

The opening screen-

At the start of the
program, you can either
create a new pathway or

load a previously created | |§ 4 Yale Center for Statistical
pathway from a file. = iZenomics and Proteomics

Create new pathway

Load existing pathway

Creating a new pathway-
' x|
Describe the pathway using the menus below

ID: 16212 Organism:
MName: Home sapiens -
Fathwrayle2l2
MName
Details:
AddSpecies

OK Cancel

When you choose to create
a new pathway, you must
provide it with an ID
number, a descriptive
name and the organism
shown. A default name is
generated automatically.
You can change this name
at any point in creating the
diagram by selecting Edit
-> Pathway Details from
the main menu.




Loading a pathway from file -

You can load a Look In: =) filles v| 510988 e
pathway from file, as

i alanitie xmnl
long as it was ]
ataoml
enerated by VitaPad L‘ﬁ r
& Y My Recent testGraph3xml

in XML format. A Do ! testGraphd
few sample files are

i : . 7= .
included in /etc/files. L% File Name: | Open
Desktop ~ Flesof Type: | XML Files(‘aml) Cancel

Loading a pathway from the IPA database —

You can request to have

Edit Panel
a pathway generated
D Search for a defined pathway from the IPA (Integrated
Pathway Analysis)
Pathways Organism database here at Yale.

Select an organism from
Hormno sapiens M those currently available
(Homo sapiens, Mus
musculus and Rattus
metabolism norvegicus at the
moment.) Then enter a

Crrateine metabolisin

D-Arginine and D-ornithine 1
D-Glutarnine and D-glutarnate
Fatty acid metabolism ;
Fructose and mannose metal

Search Database

Zalartose metabolism
Globoside metabolism Find Clear search phrase in the text
lutarnate metabolism field and click Find to
Glutaﬂ“?n_e mEtathlsm Load Data File search the database.
Clyeeralipid metabolism Matching pathways will
Clyeine, serine and threonine .

. — appear in the text box on
Clyoxylate and dicarboxylate [+ 0K Cancel

the left. If you leave the

search field blank, all
available pathways for the species will be displayed. Press Clear to remove
matches and search again. The button currently does nothing, but in the near
future, you will be able to use it to import your own reaction data and generate a
graph using our layout algorithm.



Using the toolbar -

View , &y k¢
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Select Vertex Edge Move Edit Delete Undo/Redo Zoom In/Out

The toolbar has buttons for each of the graph views five modes of interaction
(View mode, Select/Edit mode, Add Vertex mode, Add Edge mode and Move
Component mode). Selecting one of these buttons toggles that mode on and the
others off. The same can be done through the main menu under Edit. The

modes will be discussed in detail below, but some mention should be made of
the other buttons. The Edit and Delete buttons work as part of the Select/Edit
mode only so they will be discussed there. Undo and Redo restore previous
unsaved versions of the graph and can be accessed from any mode. The zoom
buttons are currently inactive but will be available in future versions.

View mode -

View mode is used to show specific data about the graph
and elements on it. Elements cannot be added or moved
in this mode. In this mode, when you mouse over an

enzyme, a popup will appear showing the full name (see

right).

Display Fanel

Compound:

L-Cystathionine

H, M

2 _

Annotations:

=

N

Annotate

Go To KEGG

Trac anate
h

Histidine armmania-
lyase

L-Histidine

Clicking on enzymes or
compounds will bring
up detailed information
in the display panel (see
left). If you click
outside of an enzyme or
compound, information
for the pathway itself
will be displayed. If
you click on Go To
KEGG, a browser
window will pop up
showing the KEGG web
page with further details



about the compound,
enzyme or pathway
displayed. If you click on
Annotate, you can
provide additional
information to be saved
with your pathway (see
right).

Select/Edit mode -

Display Panel

. O
HO . =
O NH,

Annotations:

Here wou can write your own details regarding
the compound.
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Save Note Go To KEGG

This mode is used to modify or delete existing pathway components. Click on
the edges or vertices you wish to modify, holding down the shift key to select
more than one if you wish, and press the X icon to delete or the wrench icon to
edit. You can also select all compounds or links using the main menu (Edit ->
Select All -> Compounds or Links. Editing uses the same dialogs as for adding
vertices or edges, so I will discuss them below. Please note also that enzymes,
genes and expression values get edited along with the edge they are connected

to, not separately.




Add Vertex mode —

In this mode, if you click on the
graph, an animated plus cursor
will appear at the spot the
vertex will be located and the
dialog on the right will appear
in the edit panel.

The box on the left shows a
thumbnail view of saved visual
types that can be selected for
the object. The window at the
bottom of the dialog shows a
preview of how the selected
compound will appear using
this type. For types too large to
appear in a thumbnail (e.g.
those using a large font), you
can see a full-sized view by
mousing over the scope icon.

Edit Panel

{? Describe the vertex using the menus below

Visual Types

Image | Name |

Compound

2-Cicobutano ate

b

pray

Select Compound

Edit Visual Properties

OK Cancel

2-Oxobutanoate

New visual types can be created by clicking on Edit Visual Properties. To select
a different compound, click on Select Compound.

Edit Panel

Compounds

2-Oxoglutarate

Search

2-Oeoglitaramate < glut

{? Search for a compound or add a new one

3-Methylalutaconyl-Cod

Clear

1-Hy droxy-2-oxoglitarate
4-Hyrdroxor-d-rnethyl-2-oxo
4-Hyrdrosor-d-tnethylglutar
4-Hydrosorphenylacetsylgla
4-Methyl-L-glutarmate

Compound Name

4-Methylene-2-oxo glutaral
4-Methylene-L-glutarnate

Add new compound

4-Methylene-L-glutarnire

4-Creoglutararmate —
-

A ] 2] |

Cancel

graph.

The dialog to select a
compound is pictured
on the left. Type a
search phrase in the text
tield and matching
compounds from the
IPA database will be
returned. If you leave
the field blank, all
compounds will be
returned. If you cannot
find your compound,
you can type a name in
the lower text field and
click Add new
compound. The
compound will now be
stored along with your




Edit Panel

ﬂ Edit app earance using the menus below

Font Colors
Palatine Linotype - Outline: ]
I aawvi o Fill: l—
SansSerit -
ot
Plain » 10 P oint -
Save Type
Shape
Rectangle - OK Cancel

2-Oxoglutarate

The dialog to edit
vertices is pictured at
left. The font box
allows you to select from
any font available on
your system. With the
combo box below, you
can select style (plain,
bold or italic) and point
size. Below Shape, you
can select from the
following: rectangle,
ellipse and rounded
rectangle. In future
versions, more shapes
will be made available
as well as the ability to
create a custom shape.

You can choose the color scheme for the compound, by clicking on the
appropriate colored button. Once the appearance is to your liking, you can save
it to disk by clicking on Save Type. Now, the shape will be available for ready
access from the thumbnail menu in the Add Vertex dialog. The window at the
bottom of the dialog shows a preview of your customized type.

Add Edge mode -

To add an edge, click the
tirst element on the graph
you wish to connect and
then the second. Usually,

you will connect two
vertices, but it is also

possible to draw an edge

to another edge. In this

case you would click an
existing edge on the graph.

The dialog for adding

edges is similar to that for

adding vertices. Again

there is a thumbnail menu

containing default and

Edit Panel

‘2"l Describe the link using the menus below

Visual Types

Image | MName |

Endpoints
1.: L-Glutamate

2.: 2-Oxoglutarate

Edit Visual Properties
*
4 Add Enzyme(s)
Y
OK Cancel
Forward -

Y




previously saved types and a preview window. Below the thumbnail menu, is a
combo box allowing you to specify the direction of the arrow. The options are
forward: endpoint 1 to endpoint 2, backward: endpoint 2 to endpoint 1, both
ways and neither for an undirected edge. If one or both of your endpoints is
another edge, you can select the relative placement of the new edge (0.5, or at the
midpoint, is the default). You can add enzymes to the edge by clicking on Add
Enzyme(s) and change the appearance by clicking Edit Visual Properties.

Edit Panel The dialog to edit edges
is picture on the left.
The arrow type combo
box allows you to select
Colors: either a solid or dotted
Arrow Type: line. In the future,
Armow: ([ additional types, such as
the flat-ended edge for
inhibition reactions, will

,2" Edit app earance using the menus below

Body: Solid

Save Type .
Curvature: be available as well as
the ability to draw your
Rate: 0= 0K Cancel own edge type. The

rate of curvature takes
values from O to 1. At
this point, anything
higher than 0 will apply
the same degree of
curvature (i.e., a line is

Y

either curved or it is not). This feature is currently rather limited, but it will be
enhanced in future versions. Please note also that you cannot currently attach
an enzyme to a curved edge. You can choose the color of the edge by selecting
the colored button. By clicking Save Type, you can save your custom type to
disk. Now this type will be easily available from the thumbnail menu in the Add
Edge dialog.



Ve

Visual Types

Image | Name |

Typel

Edit Panel

Add enzymes using the menus below

@D | @

Enzymes
E.C. | MName |
1413 =
Select Enzyme
Edit Delete
OK Cancel

The dialog to add
enzymes is pictured on
the left. This menu is
quite similar to that for
adding vertices, so I will
summarize briefly. The
thumbnail menu shows
saved types. The Edit
button allows you to
customize the enzyme’s
appearance using the
same menu as that to
edit the appearance of
vertices. Clicking Select
Enzyme brings up a
dialog to choose an
enzyme. Delete will

remove the highlighted

enzyme from the edge. Note that an edge can contain any number of enzymes,

including none.

The dialog to select an
enzyme is show on the right.
To select an enzyme, enter
search criteria in the text
field below Search and
matching enzymes from the
IPA database will be shown.
You can search either a
numerical sequence in the
E.C. number or a string from
the full name of the enzyme.
If your enzyme is not found,
you can enter a new one by
filling in the Enzyme ID and
Enzyme Name fields and
clicking Add new enzyme.
Your new enzymes will now
be stored along with your
graph.

Edit Panel
‘2 Select an enzyme or add a new one
Enzymes Search
EC. | N ame | 24
2124 -
2324 3 Find Clear
2411
24110 Enzyme ID
241100 . N
241101 nzyme Name
241102
241103
241104 Add new enzyme
241105
241108 n — Coancel
241107 b’




Move mode -

In move mode, you can move elements on the graph by simply clicking on
vertices and dragging them to the new location. The graph is updated as the
element is moved. As the vertex moves, the edges connected to it move in
conjunction. Please note that decorations such as enzymes, genes and
expression values move with the edge they are attached to and cannot be moved
separately.

Loading experiment data -

. Edit Panel
To map experlmental

data onto a pathway Select an exp eriment from the menu
diagram, select File ->
Load Experiment from
the main menu. The

dialog for selecting an 12| ingulin

Experiments Search Database

experiment is shown DT i p
. -nsulin-sensitive |~ Find Clear
on the rlght'_ You can GDS158-nsulin-resistant (73
select load either one or GDS158-insulin-s ensitive
two experiments to GDS160-insulin-resistant Load Data File
display. If you select GDS160-insulin-sensitive |
two, the value GDS161-insulinresistant |
displayed will be the GDS16T-insulin-sensitive A Details E dit
ratio of values for the
. . GDSla0-insulin-re sistant
two (Experiment 1 / 1 mstiresistat
X OK Cancel
Experiment 2). To 2: Mone

load an experiment
from the IPA database, enter search criteria from the text field under Search
Database and click Find. All matching experiments are displayed in the text box

on the left. If you leave the field blank, all available experiments will be
displayed. In the near future, you will be able to enter your own experiment
data by clicking on Load Data File. Clicking on Details will open a text box
with a description of the experiment.



Edit Panel

. . ) Before you can display
\P Define the gradient to use )
the experiment data,

you must click on Edit
n - Colors to create the gradient

165.583 Win: pattern to color the
Wase: I—- values. The Edit

[y 113167 Gradient dialog is
T Ilicl: /A
shown on the left. The
60.75 No Value: | current gradient is
U ~ga3a Values shown on the left side of
M 5333 | the dialogalong with a
slider showing the range
Wlax: 218
of values. A small

rectangle is shown for

Save Type Load OK Cancel

each data value in the

experiment and a
preview window
indicates how the data value will appear using the gradient. By moving the
slider, you can get an idea of how your data values will appear. You can adjust
the color values used to define the gradient by clicking on the colored buttons.
Mid is the color used to represent a 1 : 1 ratio for two experiments. In addition,
you can adjust the minimum and maximum values for the gradient using the
corresponding text fields. By default, these are set to the maximum and
minimum values of the experiment data. If you click on Save Type, you can
save your custom to disk for future use.

Saving your pathway —

You can save your pathway in two ways: as an image or as data. To save as data
select File -> Save File from the main menu. This will save the file in our custom
XML format and will allow you to load and modify the data at a later time. To
save a PNG image of the graph, select File -> Save Image from the main menu.

Printing your pathway -
You can send an image of your graph by selecting File -> Print from the main

menu. The print preview option (File -> Print Preview) is currently not
functional, but will be enabled for future releases.



Table View -

The table view for the graph can be accessed by selecting Edit -> Table View from
the main menu. Please note that the table view is primarily for display purposes
at this point. In the near future, you will be able to edit graph components using
the same dialogs as for the graph view and select elements to include by clicking
on their check box. Currently, you can sort the elements in ascending or
descending alphabetical order using the arrow icons in the column header cells.

Compounds | Edges | Enzymes |

? T.,L| Name T.,L| Type | Connects | X 'T‘.,J,| Y T.L|
[ A L-Asparagine B| Type L-Aspartate - |7 52 237 :
v 4] coz E Carbonic acid v | 28 148
vl |4 Glyeine E MH3 Bl 319 347
¥ |4 Urocanate E| L-Histidine r* 424 85
¥ |4 Carbamoyl plosphate |E Type ITH3 - | 248 385 m
1] 4 2-Oxoglutarate E| Type L-Glutamnate r 177 65

v |4 L-Glutamine El Type IH3 - P 178 237

v 4 L-Cysteine E| L-Cystathionine r# 563 293

[w] 4| L-Ghtamate B| Type 2-Oxoghitarate - | 177 137 [

f /
Edit Show details Goto component

The figure above shows the table view for compounds; views for edges or
enzymes can be seen by clicking on the appropriate tabs.

Additional information —

Please contact me if you have any questions or comments regarding this
software:

Matt Holford
Yale Center For Statistical Genomics
matthew.holford@yale.edu
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